Problem in playing the animations

Mar 28, 2012 at 11:14 AM
Edited Mar 28, 2012 at 11:15 AM

Hello, I recently discovered your tool and I was amazed by it, so I gave it a try. Unfortunately, I cannot get it to work and I don't know what am I doing wrong.

In the editor everything works fine, but when I click Play the animation is messed up. The same thing happens even if I load the guy_walk from your tutorial. Here 2 videos demonstrating the problem.

My build:

http://www.youtube.com/watch?v=vy9GfPUtbWU

Using your animation:

http://www.youtube.com/watch?v=ik4apB_uxV8

 

If I try to play your animation from an XNA project everything works fine, but when trying playing one of my animations the problem is still there. Any ideas, thanks a lot.

Coordinator
Mar 28, 2012 at 1:47 PM
Edited Mar 28, 2012 at 1:55 PM

Well that's all kinds of wacky. Thanks for taking the time to report the problem.

Did you download from svn or from the zip file?

Also, if you're building from source, which version are you using? (XNA 3.1 or 4.0 version?)

Coordinator
Mar 28, 2012 at 4:20 PM

Okay, everything is working fine on my end, but I have a theory. I believe something is being corrupted when the file is saved in Demina.

When you hit play in Demina, it saves the file out to a temporary file, then that file is loaded up in DeminaViewer. This explains why both my animation and the ones you create aren't working inside Demina, yet mine works and yours doesn't when loaded in another XNA project. (I imagine if you saved my animation out to a new file, then tried to load it up, it would be broken.)

To verify this, could you send me one of your animations? (I only need the .anim file, if you're using the same images from the tutorial project.) You can send it to jessechounard@gmail.com.

Mar 28, 2012 at 4:22 PM
Edited Mar 28, 2012 at 4:30 PM

First of all, thanks for the very quick response.

I used the zip file. My OS is Windows 7 Proffesional 64-bit, if that plays any role.

Edit: Post at the same time. I am reading now your 2nd post. :P

Edit2: Email sent!

Coordinator
Mar 28, 2012 at 5:00 PM

Yep, it was an issue with file saving. The current binaries don't properly save as culture invariant, so the floating point numbers get written out with a comma instead of a period as the decimal separator. When reading back in, everything gets broken. This bug was fixed quite awhile back, but we never uploaded new binaries. (The fix was check into svn back in April of last year.)

If you don't mind, try grabbing the latest version of the source code, compile that, and see if it works better. Sorry for the inconvenience. I'll try to upload some new binaries soon.

Mar 29, 2012 at 9:52 AM
Edited Mar 29, 2012 at 9:52 AM

Everything worked like a charm! Thanks a lot for your help and quick responses. I am going to play around with Demina now!